Branch: refs/heads/nozzle-tests-macros2 Home: https://github.com/kronosnet/kronosnet Commit: 4798efae1393add49af961653dda33befeb67f68 https://github.com/kronosnet/kronosnet/commit/4798efae1393add49af961653dda33... Author: “xuxiaojuan1” xuxiaojuan@kylinos.cn Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M configure.ac M libknet/handle.c M libknet/threads_common.h
Log Message: ----------- handle.c:Add unique names to handle threads
Commit: 3e1d50cc52d2900cfe45e417a22e456afb823f03 https://github.com/kronosnet/kronosnet/commit/3e1d50cc52d2900cfe45e417a22e45... Author: Fabio M. Di Nitto fdinitto@redhat.com Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M Makefile.am
Log Message: ----------- build: add CLAUDE.md to release tarball
CLAUDE.md provides AI-assisted development documentation and should be included in release tarballs for completeness.
Signed-off-by: Fabio M. Di Nitto fabbione@kronosnet.org Co-Authored-By: Claude Sonnet 4.5 noreply@anthropic.com
Commit: dfa4af52288be18015ed758073a3076be65b5369 https://github.com/kronosnet/kronosnet/commit/dfa4af52288be18015ed758073a307... Author: Fabio M. Di Nitto fdinitto@redhat.com Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M README
Log Message: ----------- docs: update OpenIndiana build instructions
Simplify version references for better long-term documentation maintainability by using generic package names instead of specific version numbers.
Signed-off-by: Fabio M. Di Nitto fabbione@kronosnet.org Co-Authored-By: Claude Sonnet 4.5 noreply@anthropic.com
Commit: 0674c8c04989e64318227a326d3d4e2cfb772545 https://github.com/kronosnet/kronosnet/commit/0674c8c04989e64318227a326d3d4e... Author: Fabio M. Di Nitto fdinitto@redhat.com Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M Makefile.am R README A README.md
Log Message: ----------- docs: convert README to markdown format
Rename README to README.md and convert to proper markdown formatting for better readability on GitHub and other platforms.
Signed-off-by: Fabio M. Di Nitto fabbione@kronosnet.org Co-Authored-By: Claude Sonnet 4.5 noreply@anthropic.com
Commit: 91b16aaf04ca5bd2f5b9a1b78db0998b3187319c https://github.com/kronosnet/kronosnet/commit/91b16aaf04ca5bd2f5b9a1b78db099... Author: Fabio M. Di Nitto fdinitto@redhat.com Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M libknet/tests/Makefile.am M libknet/tests/api_knet_handle_add_datafd.c
Log Message: ----------- tests: add coverage for connected named AF_UNIX SOCK_STREAM sockets
Add test case for knet_handle_add_datafd with a connected named AF_UNIX SOCK_STREAM socket to verify the happy path after commit cb896d8f.
The test creates a Unix domain socket server in ABSBUILDDIR, connects a client, and validates that knet accepts the connected socket. Gracefully skips if the build path exceeds sun_path length limit.
Added CLEANFILES rule to remove socket test artifacts during make clean.
Signed-off-by: Fabio M. Di Nitto fabbione@kronosnet.org Co-Authored-By: Claude Sonnet 4.5 noreply@anthropic.com
Commit: cf471e66c596baca3b1bce973be4f90449913a1d https://github.com/kronosnet/kronosnet/commit/cf471e66c596baca3b1bce973be4f9... Author: Christine Caulfield ccaulfie@redhat.com Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths: M libnozzle/tests/api_nozzle_add_ip.c M libnozzle/tests/api_nozzle_close.c M libnozzle/tests/api_nozzle_del_ip.c M libnozzle/tests/api_nozzle_get_fd.c M libnozzle/tests/api_nozzle_get_handle_by_name.c M libnozzle/tests/api_nozzle_get_ips.c M libnozzle/tests/api_nozzle_get_mac.c M libnozzle/tests/api_nozzle_get_mtu.c M libnozzle/tests/api_nozzle_get_name_by_handle.c M libnozzle/tests/api_nozzle_open.c M libnozzle/tests/api_nozzle_prefix_validation.c M libnozzle/tests/api_nozzle_run_updown.c M libnozzle/tests/api_nozzle_set_down.c M libnozzle/tests/api_nozzle_set_mac.c M libnozzle/tests/api_nozzle_set_mtu.c M libnozzle/tests/api_nozzle_set_up.c M libnozzle/tests/int_execute_bin_sh_command.c M libnozzle/tests/test-common.h
Log Message: ----------- nozzle: Introduce test macros similar to libknet
Add comprehensive test macros to test-common.h, similar to those used in libknet tests: - FAIL_ON_ERR: Fail if function returns error - FAIL_ON_SUCCESS: Negative test - expect failure with specific errno - FAIL_ON_NULL/FAIL_ON_NOT_NULL: For pointer-returning functions - FAIL_ON_NONZERO/FAIL_ON_ZERO: For comparisons - FAIL_ON_ERR_ONLY: For functions returning -1 on error - FAIL_ON_CMD: For execute_bin_sh_command and similar - FAIL_ON_CMD_SUCCESS: Negative test for commands
These macros: - Reduce code duplication and improve readability - Print descriptive failure messages with line numbers - Handle errno correctly for debugging - Automatically clean up via 'goto out_clean' pattern
All test files have been converted to use these macros, significantly reducing test code size (from 1280 to ~600 lines net) while improving clarity and error reporting.
Also fixed Solaris-specific test issues where interface state checks aren't possible - these now skip the check rather than fail.
Co-Authored-By: Claude Sonnet 4.5 noreply@anthropic.com
Compare: https://github.com/kronosnet/kronosnet/compare/4798efae1393%5E...cf471e66c59...
To unsubscribe from these emails, change your notification settings at https://github.com/kronosnet/kronosnet/settings/notifications