Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: 9c3839aa2c0b0636d417240f8e464555a86cff2c
https://github.com/kronosnet/kronosnet/commit/9c3839aa2c0b0636d417240f8e464…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M libnozzle/libnozzle.c
M libnozzle/libnozzle.h
Log Message:
-----------
[nozzle] rename last tap bits to nozzle
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: 0dbbb1f06995eee7bf71b27a5d86ce05c567140c
https://github.com/kronosnet/kronosnet/commit/0dbbb1f06995eee7bf71b27a5d86c…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M libnozzle/api-test-coverage
M libnozzle/libnozzle.c
M libnozzle/libnozzle.h
M libnozzle/libnozzle_exported_syms
Log Message:
-----------
[nozzle] rename API from tap_ to nozzle_
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: 3095f30c33c23d29191ee37326b10b7e655c2978
https://github.com/kronosnet/kronosnet/commit/3095f30c33c23d29191ee37326b10…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M libnozzle/libnozzle.c
M libnozzle/libnozzle.h
Log Message:
-----------
[nozzle] rename struct _iface to nozzle_iface (looks better on public headers)
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: c0f17d144f87c93129e2a04bd052c9fb7546ac65
https://github.com/kronosnet/kronosnet/commit/c0f17d144f87c93129e2a04bd052c…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M libnozzle/libnozzle.c
M libnozzle/libnozzle.h
Log Message:
-----------
[nozzle] rename tap_t to nozzle_t
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: ec53fabec0e47599bf53beab795e3fc17919ac4c
https://github.com/kronosnet/kronosnet/commit/ec53fabec0e47599bf53beab795e3…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M libnozzle/libnozzle.h
Log Message:
-----------
[nozzle] include net/if.h to define IFNAMSIZ instead of redefine
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Branch: refs/heads/libtap-fixes
Home: https://github.com/kronosnet/kronosnet
Commit: 68fa70f0675bfe63916d055b059141c76ba2bfb7
https://github.com/kronosnet/kronosnet/commit/68fa70f0675bfe63916d055b05914…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2017-11-16 (Thu, 16 Nov 2017)
Changed paths:
M Makefile.am
M NOTES_TO_PACKAGE_MAINTAINERS
M README
M configure.ac
M kronosnet.spec.in
M kronosnetd/Makefile.am
M kronosnetd/cfg.c
M kronosnetd/cfg.h
M kronosnetd/vty_cli_cmds.c
A libnozzle/Makefile.am
A libnozzle/api-test-coverage
A libnozzle/libnozzle.c
A libnozzle/libnozzle.h
A libnozzle/libnozzle.pc.in
A libnozzle/libnozzle_exported_syms
A libnozzle/tap_updown_bad/down.d/kronostest
A libnozzle/tap_updown_bad/post-down.d/kronostest
A libnozzle/tap_updown_bad/pre-up.d/kronostest
A libnozzle/tap_updown_bad/up.d/kronostest
A libnozzle/tap_updown_good/down.d/kronostest
A libnozzle/tap_updown_good/post-down.d/kronostest
A libnozzle/tap_updown_good/pre-up.d/kronostest
A libnozzle/tap_updown_good/up.d/kronostest
R libtap/Makefile.am
R libtap/api-test-coverage
R libtap/libtap.c
R libtap/libtap.h
R libtap/libtap.pc.in
R libtap/libtap_exported_syms
R libtap/tap_updown_bad/down.d/kronostest
R libtap/tap_updown_bad/post-down.d/kronostest
R libtap/tap_updown_bad/pre-up.d/kronostest
R libtap/tap_updown_bad/up.d/kronostest
R libtap/tap_updown_good/down.d/kronostest
R libtap/tap_updown_good/post-down.d/kronostest
R libtap/tap_updown_good/pre-up.d/kronostest
R libtap/tap_updown_good/up.d/kronostest
Log Message:
-----------
[libnozzle] rename libtap to libnozzle (part 1)
Our fearless Debian maintainer wferi made us aware that TAP is an overloaded
term already and it would be very confusing to add yet another one.
nozzle is a good pick from http://www.thesaurus.com/browse/tap
I am sure lib*cock* would have cause havoc :-)
This commit only rename files and allow builds. The API needs to be renamed too,
but that will come over time with major code cleanup as documented here:
https://trello.com/c/pyEKd4UH/396-libnozzle-make-it-production-ga-ready
Signed-off-by: Fabio M. Di Nitto <fdinitto(a)redhat.com>