Branch: refs/heads/stable1-proposed
Home: https://github.com/kronosnet/kronosnet
Commit: 72571ed61031018fde5870be55b2af9c7198443a
https://github.com/kronosnet/kronosnet/commit/72571ed61031018fde5870be55b2a…
Author: Christine Caulfield <ccaulfie(a)redhat.com>
Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths:
M libnozzle/tests/api_nozzle_prefix_validation.c
Log Message:
-----------
nozzle: Introduce test macros similar to libknet
Add comprehensive test macros to test-common.h, similar to those used
in libknet tests:
- FAIL_ON_ERR: Fail if function returns error
- FAIL_ON_SUCCESS: Negative test - expect failure with specific errno
- FAIL_ON_NULL/FAIL_ON_NOT_NULL: For pointer-returning functions
- FAIL_ON_NONZERO/FAIL_ON_ZERO: For comparisons
- FAIL_ON_ERR_ONLY: For functions returning -1 on error
- FAIL_ON_CMD: For execute_bin_sh_command and similar
- FAIL_ON_CMD_SUCCESS: Negative test for commands
These macros:
- Reduce code duplication and improve readability
- Print descriptive failure messages with line numbers
- Handle errno correctly for debugging
- Automatically clean up via 'goto out_clean' pattern
All test files have been converted to use these macros, significantly
reducing test code size (from 1280 to ~600 lines net) while improving
clarity and error reporting.
Also fixed Solaris-specific test issues where interface state checks
aren't possible - these now skip the check rather than fail.
Co-Authored-By: Claude Sonnet 4.5 <noreply(a)anthropic.com>
To unsubscribe from these emails, change your notification settings at https://github.com/kronosnet/kronosnet/settings/notifications
Branch: refs/heads/main
Home: https://github.com/kronosnet/kronosnet
Commit: 5c5e6acb95e96a569ed6141d2ec245728482ce98
https://github.com/kronosnet/kronosnet/commit/5c5e6acb95e96a569ed6141d2ec24…
Author: Christine Caulfield <ccaulfie(a)redhat.com>
Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths:
M libnozzle/tests/api_nozzle_prefix_validation.c
Log Message:
-----------
nozzle: Introduce test macros similar to libknet
Add comprehensive test macros to test-common.h, similar to those used
in libknet tests:
- FAIL_ON_ERR: Fail if function returns error
- FAIL_ON_SUCCESS: Negative test - expect failure with specific errno
- FAIL_ON_NULL/FAIL_ON_NOT_NULL: For pointer-returning functions
- FAIL_ON_NONZERO/FAIL_ON_ZERO: For comparisons
- FAIL_ON_ERR_ONLY: For functions returning -1 on error
- FAIL_ON_CMD: For execute_bin_sh_command and similar
- FAIL_ON_CMD_SUCCESS: Negative test for commands
These macros:
- Reduce code duplication and improve readability
- Print descriptive failure messages with line numbers
- Handle errno correctly for debugging
- Automatically clean up via 'goto out_clean' pattern
All test files have been converted to use these macros, significantly
reducing test code size (from 1280 to ~600 lines net) while improving
clarity and error reporting.
Also fixed Solaris-specific test issues where interface state checks
aren't possible - these now skip the check rather than fail.
Co-Authored-By: Claude Sonnet 4.5 <noreply(a)anthropic.com>
Commit: 45470b8f0ed7e969cbb34dbbef221314e426f327
https://github.com/kronosnet/kronosnet/commit/45470b8f0ed7e969cbb34dbbef221…
Author: Fabio M. Di Nitto <fdinitto(a)redhat.com>
Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths:
M libnozzle/tests/api_nozzle_prefix_validation.c
Log Message:
-----------
Merge pull request #498 from kronosnet/nozzle-tests-macros2
nozzle: Introduce test macros similar to libknet
Compare: https://github.com/kronosnet/kronosnet/compare/aa90d90a465c...45470b8f0ed7
To unsubscribe from these emails, change your notification settings at https://github.com/kronosnet/kronosnet/settings/notifications
Branch: refs/heads/nozzle-tests-macros2
Home: https://github.com/kronosnet/kronosnet
Commit: 5c5e6acb95e96a569ed6141d2ec245728482ce98
https://github.com/kronosnet/kronosnet/commit/5c5e6acb95e96a569ed6141d2ec24…
Author: Christine Caulfield <ccaulfie(a)redhat.com>
Date: 2026-07-13 (Mon, 13 Jul 2026)
Changed paths:
M libnozzle/tests/api_nozzle_prefix_validation.c
Log Message:
-----------
nozzle: Introduce test macros similar to libknet
Add comprehensive test macros to test-common.h, similar to those used
in libknet tests:
- FAIL_ON_ERR: Fail if function returns error
- FAIL_ON_SUCCESS: Negative test - expect failure with specific errno
- FAIL_ON_NULL/FAIL_ON_NOT_NULL: For pointer-returning functions
- FAIL_ON_NONZERO/FAIL_ON_ZERO: For comparisons
- FAIL_ON_ERR_ONLY: For functions returning -1 on error
- FAIL_ON_CMD: For execute_bin_sh_command and similar
- FAIL_ON_CMD_SUCCESS: Negative test for commands
These macros:
- Reduce code duplication and improve readability
- Print descriptive failure messages with line numbers
- Handle errno correctly for debugging
- Automatically clean up via 'goto out_clean' pattern
All test files have been converted to use these macros, significantly
reducing test code size (from 1280 to ~600 lines net) while improving
clarity and error reporting.
Also fixed Solaris-specific test issues where interface state checks
aren't possible - these now skip the check rather than fail.
Co-Authored-By: Claude Sonnet 4.5 <noreply(a)anthropic.com>
To unsubscribe from these emails, change your notification settings at https://github.com/kronosnet/kronosnet/settings/notifications